Составить программу в Паскаль АВС
Найти среднее арифметическое элементов массива. Найти сумму элементов массива, которые меньше среднего арифметического.
Ответы на вопрос
Ответил anknown
0
const
maxN = 100; // Максимальное кол-во элементов массива
var
n, i: longint;
middle, sum, sum2: real; // Может быть нецелым числом
a: array[1..maxN] of real;
begin
write('Введите количество элементов массива: ');
readln(n);
sum := 0; // Считаем сумму всех элементов, чтобы найти среднее арифметическое
write('Введите элементы массива через пробел: ');
for i := 1 to n do begin
read(a[i]);
sum := sum + a[i];
end;
middle := sum / n; // Вычисляем среднее арифметическое
writeln('Среднее арифметическое = ', middle);
sum2 := 0; // Считаем сумму элеметов, меньших среднего арифметического
for i := 1 to n do
if a[i] < middle then
sum2 := sum2 + a[i];
writeln('Сумма элементов, меньших среднего арифметического = ', sum2);
end.
maxN = 100; // Максимальное кол-во элементов массива
var
n, i: longint;
middle, sum, sum2: real; // Может быть нецелым числом
a: array[1..maxN] of real;
begin
write('Введите количество элементов массива: ');
readln(n);
sum := 0; // Считаем сумму всех элементов, чтобы найти среднее арифметическое
write('Введите элементы массива через пробел: ');
for i := 1 to n do begin
read(a[i]);
sum := sum + a[i];
end;
middle := sum / n; // Вычисляем среднее арифметическое
writeln('Среднее арифметическое = ', middle);
sum2 := 0; // Считаем сумму элеметов, меньших среднего арифметического
for i := 1 to n do
if a[i] < middle then
sum2 := sum2 + a[i];
writeln('Сумма элементов, меньших среднего арифметического = ', sum2);
end.
Новые вопросы
История,
2 года назад
Русский язык,
2 года назад
Алгебра,
9 лет назад
Математика,
10 лет назад
Алгебра,
10 лет назад