Информатика, вопрос задал NellFushigura , 1 год назад

Составить программу в PascalABC которая будет выводить перевёрнутое ведёное заглавными буквами​

Ответы на вопрос

Ответил a87086828
2

Ответ:

Объяснение:

program ReverseAndUppercase;

var

 input: string;

function ReverseString(s: string): string;

var

 i: integer;

begin

 Result := '';

 for i := length(s) downto 1 do

   Result := Result + s[i];

end;

function StringToUpperCase(s: string): string;

var

 i: integer;

begin

 Result := '';

 for i := 1 to length(s) do

   Result := Result + UpCase(s[i]);

end;

begin

 Write('Введите строку: ');

 ReadLn(input);

 input := StringToUpperCase(input);

 input := ReverseString(input);

 WriteLn('Перевёрнутая строка в верхнем регистре: ', input);

end.

Приложения:
Новые вопросы