Составить программу в PASCAL.
Ввести размерность матрицы и значения ее элементов.
Определить максимальный и минимальный элемент. Переставить их местами.
Найти среднее арифметическое отрицательных элементов в i-ой строке.
Ответы на вопрос
Ответил Аноним
0
var
m,n,i,j,max,min,imx,imn,jmn,jmx,k,p:integer;
s:real;
a:array[,]of integer;
begin
write('Число строк: ');
readln(m);
write('Число столбцов: ');
readln(n);
setlength(a,m+1,n+1);
for i:=1 to m do
begin
writeln('Вводите элементы строки ',i,' по одному');
for j:=1 to n do readln(a[i,j]);
end;
min:=a[1,1];
max:=a[1,1];
imn:=1;
jmn:=1;
imx:=1;
jmx:=1;
for i:=1 to m do
for j:=1 to n do
begin
if a[i,j]<min then
begin
min:=a[i,j];
imn:=i;
jmn:=j;
end;
if a[i,j]>max then
begin
max:=a[i,j];
imx:=i;
jmx:=j;
end;
end;
p:=a[imn,jmn];
a[imn,jmn]:=a[imx,jmx];
a[imx,jmx]:=p;
writeln('Измененный массив:');
for i:=1 to m do
begin
for j:=1 to n do write(a[i,j]:5);
writeln;
end;
write('Введите номер строки: ');
readln(i);
for j:=1 to n do
if a[i,j]<0 then
begin
s:=s+a[i,j];
k:=k+1;
end;
writeln('Ср.ариф. отр.чисел в строке: ',s/k);
end.
m,n,i,j,max,min,imx,imn,jmn,jmx,k,p:integer;
s:real;
a:array[,]of integer;
begin
write('Число строк: ');
readln(m);
write('Число столбцов: ');
readln(n);
setlength(a,m+1,n+1);
for i:=1 to m do
begin
writeln('Вводите элементы строки ',i,' по одному');
for j:=1 to n do readln(a[i,j]);
end;
min:=a[1,1];
max:=a[1,1];
imn:=1;
jmn:=1;
imx:=1;
jmx:=1;
for i:=1 to m do
for j:=1 to n do
begin
if a[i,j]<min then
begin
min:=a[i,j];
imn:=i;
jmn:=j;
end;
if a[i,j]>max then
begin
max:=a[i,j];
imx:=i;
jmx:=j;
end;
end;
p:=a[imn,jmn];
a[imn,jmn]:=a[imx,jmx];
a[imx,jmx]:=p;
writeln('Измененный массив:');
for i:=1 to m do
begin
for j:=1 to n do write(a[i,j]:5);
writeln;
end;
write('Введите номер строки: ');
readln(i);
for j:=1 to n do
if a[i,j]<0 then
begin
s:=s+a[i,j];
k:=k+1;
end;
writeln('Ср.ариф. отр.чисел в строке: ',s/k);
end.
Новые вопросы
История,
2 года назад
Математика,
9 лет назад
Обществознание,
9 лет назад
Математика,
10 лет назад
История,
10 лет назад