Информатика, вопрос задал Dasha40984 , 1 год назад

Составить программу в Pascal. С клавиатуры вводится трехзначное число N. Вычислить цифры данного числа без использования функции деления с остатком MOD, возвести в куб каждое из чисел и сложить. ​

Ответы на вопрос

Ответил khsnln
1

полученное число переводится в строку, строка посимвольно разбивается на три переменные, каждая из которой переводится обратно в число.

var N, m, s, k: string;

     N1, a, b, c ,d : integer;

begin

readln(N);

N1:=inttostr(N);

m := copy(N1, 1, 1);

s := copy(N1, 2, 1);

k := copy(N1, 3, 1);

a:= strtoint(m);

b:= strtoint(s);

c:= strtoint(k);

d:=a*a*a+b*b*b+c*c*c;

writeln(d);

end


Dasha40984: Спасибо, к сажалению, мы не проходили такие функции как inttostr, copy и т. д. поэтому учитель не принет это. Но все равно спасибо за помощь)
Ответил BobbyFresnel
1

===== PascalABC.NET =====

begin

 ReadInteger.ToString.Select(c -> c.ToDigit ** 3).Sum.Println

end.

Приложения:

Dasha40984: Хех, это тоже он не примет. Но спасибо за помощь))
Новые вопросы