Информатика, вопрос задал dkapnina , 10 лет назад

Составить программу (в Pascal) позволяющую найти минимальный элемент  массива. Подсчитать количество элементов в массиве, равных минимальному. Размеренность массива произвольная.

Ответы на вопрос

Ответил spel3fo
0
Program my;
var  k,i,z:integer; 
     a:array[1...N]:integer; 
begin
k:=99999;
for i:=1 to N do                   
 if a[i]<k then k:=a[i];
z:=0;
for i:=1 to N do 
 if a[i]=k then z:=z+1;
end.
=)  
Ответил spel3fo
0
read(a[i]);
Ответил Sky09
0
Люди, которые знают паскаль, не будут выкладывать сюда подобные элементарные задачи, а значит и решение было бы желательно писать полностью. К тому же Ваша программа без ввода массива даже работать не будет.
Ответил Sky09
0
И константу N Вы не описали.
Ответил Sky09
0
Плюс, на собственном опыте знаю, что нельзя минимальное значение (в Вашем случае k) задавать определенным числом. Если все элементы массива будут больше этого k, то и минимальный по такому коду найден не будет в данном массиве. Это не упрек, а просто совет. Примите к сведению, пожалуйста, пригодится.
Ответил Sky09
0
uses crt;
const N=10;
var a:array [1..N] of integer;
     x,min,k:integer;
begin
for x:=1 to N do
begin
write('a[',x,']:',a[x]);
readln(a[x]);
end;
min:=a[1];
for x:=1 to N do
if a[x]<min then min:=a[x];
for x:=1 to N do
if a[x]=min then inc(k);
writeln('Минимальный элемент: ',min,'. Таких элементов в массиве: ',k);
end.
Ответил Sky09
0
И впредь подобные ситуации лучше разрешать в личных сообщениях. Лишние уведомления другим пользователям ни к чему.
Ответил Sky09
0
А Вас просили решение. Мы не знаем уровня знаний этого языка пользователем. Если, допустим, она паскаль вообще не знает, то и дополнить она Ваш код никак не сможет, даже если очень захочет. И не только она. Таких пользователей здесь выше крыши. Некоторым приходится даже комментарий к каждой строчке расписывать.
Ответил spel3fo
0
ты есть в ВК?
Новые вопросы