Составить программу в Pascal, которая в тексте после каждой буквы вставляет заданный символ (с помощью стандартных процедур)
Ответы на вопрос
Ответил Аноним
0
// PascalABC.NET 3.3, сборка 1579 от 18.11.2017
// Внимание! Если программа не работает, обновите версию!
begin
var s:=ReadlnString('Введите текст:');
var c:=ReadlnChar('Введите букву для вставки');
var s1:='';
for var i:=1 to s.Length do begin
s1+=s[i];
if s[i]<>' 'then s1+=c
end;
Writeln(s1)
end.
Пример
Введите текст: Привет паскалю!
Введите букву для вставки Ы
ПЫрЫиЫвЫеЫтЫ пЫаЫсЫкЫаЫлЫюЫ!Ы
// Внимание! Если программа не работает, обновите версию!
begin
var s:=ReadlnString('Введите текст:');
var c:=ReadlnChar('Введите букву для вставки');
var s1:='';
for var i:=1 to s.Length do begin
s1+=s[i];
if s[i]<>' 'then s1+=c
end;
Writeln(s1)
end.
Пример
Введите текст: Привет паскалю!
Введите букву для вставки Ы
ПЫрЫиЫвЫеЫтЫ пЫаЫсЫкЫаЫлЫюЫ!Ы
Новые вопросы
Математика,
2 года назад
Математика,
2 года назад
Алгебра,
8 лет назад
Математика,
8 лет назад
Алгебра,
9 лет назад
Математика,
9 лет назад