Составить программу в массиве с N числами поменять местами максимальное и минимальное значения
rustemgimadutd:
какой размер массива?
Ответы на вопрос
Ответил rustemgimadutd
1
var
a:array[1..1000] of integer;
i,min,max,c,n:integer;
begin
read(n);
min:=1;max:=1;
for i:=1 to n do read(a[i]);
for i:=1 to n do begin
if a[i]>a[max] then max:=i;
if a[i]<a[min] then min:=i;
end;
c:=a[min];
a[min]:=a[max];
a[max]:=c;
for i:=1 to n do write(a[i],' ');
end.
a:array[1..1000] of integer;
i,min,max,c,n:integer;
begin
read(n);
min:=1;max:=1;
for i:=1 to n do read(a[i]);
for i:=1 to n do begin
if a[i]>a[max] then max:=i;
if a[i]<a[min] then min:=i;
end;
c:=a[min];
a[min]:=a[max];
a[max]:=c;
for i:=1 to n do write(a[i],' ');
end.
Новые вопросы
Русский язык,
2 года назад
Английский язык,
2 года назад
Математика,
2 года назад
История,
7 лет назад