составить программу в которой записать в массив N номера положительных элементов массива (x1,x2...x15)
Ответы на вопрос
var
N: array [1..15] of 1..15; {Массив, в который записываются номера положительных элементов массива х}
x: array [1..15] of real; //Массив х
i: integer; //Переменная для цикла
Number: integer; //Сколько номеров было записано
begin
Number:= 0; //Обнуляем счетчик номеров
for i:= 1 to 15 do //Вводим с клавиатуры массив х
begin
writeln('Введите ', i, ' элемент массива х');
readln(x[i]);
if x[i] > 0 then {Если введенный элемент массива х положительный, то прибавляем к счетчику добавленных номеров 1 и присваиваем соответствующему элементу массива N номер элемента}
begin
Number:= Number + 1;
N[Number]:= i;
end;
end;
write('Номера положительных элементов массива х: ');
for i:= 1 to Number do write(n[i], ' '); //Выводим записанные номера элементов
writeln; {Переход на новую строку, чтобы при следующем запуске программы информация выводилась с новой строки}
end.