Составить программу, в которой описывается структура из полей: Город, Количество жителей, Количество библиотек. Организовать ввод структурных переменных, вывод каждой структуры на экран и расчет количества библиотек на 1000 жителей.
Кол-во библиотек на 1000 жителей = Количество библиотек / Количество жителей / 1000.
С++
Ответы на вопрос
Вроде так:
#include <iostream>
#include <string>
using namespace std;
struct CityData {
string city;
int population;
int numLibraries;
};
int main() {
const int MAX_CITIES = 5; // максимальное количество городов для ввода
CityData cities[MAX_CITIES]; // массив для хранения данных о городах
int numCities; // количество городов для ввода
// получить количество городов для ввода от пользователя
do {
cout << "How many cities would you like to input (up to " << MAX_CITIES << ")? ";
cin >> numCities;
} while (numCities < 1 || numCities > MAX_CITIES);
// input data for each city
for (int i = 0; i < numCities; i++) {
cout << "Enter data for City #" << i+1 << ":" << endl;
cout << "City name: ";
cin >> cities[i].city;
cout << "Population: ";
cin >> cities[i].population;
cout << "Number of libraries: ";
cin >> cities[i].numLibraries;
}
// вывести данные по каждому городу и рассчитать количество библиотек на 1000 жителей
for (int i = 0; i < numCities; i++) {
cout << "City #" << i+1 << " data:" << endl;
cout << "City name: " << cities[i].city << endl;
cout << "Population: " << cities[i].population << endl;
cout << "Number of libraries: " << cities[i].numLibraries << endl;
double librariesPer1000 = (double)cities[i].numLibraries / cities[i].population * 1000;
cout << "Libraries per 1000 inhabitants: " << librariesPer1000 << endl;
}
return 0;
}
Ответ:
#include <iostream>
#include <string>
using namespace std;
// Определяем структуру City
struct City {
string name;
int population;
int libraries;
};
int main() {
City myCity; // Объявляем переменную структурного типа
// Запрашиваем данные у пользователя
cout << "Введите название города: ";
getline(cin, myCity.name);
cout << "Введите количество жителей: ";
cin >> myCity.population;
cout << "Введите количество библиотек: ";
cin >> myCity.libraries;
// Выводим полученные данные на экран
cout << "\nДанные города:\n";
cout << "Название: " << myCity.name << endl;
cout << "Количество жителей: " << myCity.population << endl;
cout << "Количество библиотек: " << myCity.libraries << endl;
// Расчет количества библиотек на 1000 жителей
double librariesPerThousand = static_cast<double>(myCity.libraries) / myCity.population * 1000;
// Выводим результат на экран
cout << "\nКоличество библиотек на 1000 жителей: " << librariesPerThousand << endl;
return 0;
}
Объяснение:
Программа запрашивает у пользователя название города, количество жителей и количество библиотек, после чего выводит эти данные на экран и рассчитывает количество библиотек на 1000 жителей.