Информатика, вопрос задал maks37911 , 1 год назад

Составить программу упорядочение элементов по убыванию в третей строке матрицы A (N,N). на языке С

Ответы на вопрос

Ответил daniil062
1

Ответ:

#include <stdio.h>

#include <stdlib.h>

#define N 3

int main()

{

   int A[N][N], i, j, temp;

   printf("Enter elements of matrix A: \n");

   for (i = 0; i < N; i++)

   {

       for (j = 0; j < N; j++)

       {

           scanf("%d", &A[i][j]);

       }

   }

   for (i = 0; i < N; i++)

   {

       for (j = i + 1; j < N; j++)

       {

           if (A[2][i] < A[2][j])

           {

               temp = A[2][i];

               A[2][i] = A[2][j];

               A[2][j] = temp;

           }

       }

   }

   printf("Matrix A in descending order: \n");

   for (i = 0; i < N; i++)

   {

       for (j = 0; j < N; j++)

       {

           printf("%d\t", A[i][j]);

       }

       printf("\n");

   }

   return 0;

}

Объяснение:

Эта программа определяет матрицу 3x3 «A» и предлагает пользователю ввести ее элементы. Затем она использует вложенные циклы for и оператор if для сортировки элементов третьей строки (то есть от A[2][0] до A[2][2]) в порядке убывания с использованием алгоритма пузырьковой сортировки. Наконец, она выводит отсортированную матрицу.

Новые вопросы