Составить программу удаляющую из данного текста все буквосочетания «ма» и выводящую получившийся текст и его длину.
Ответы на вопрос
Ответил Gleb1Kosyrev
0
//Pascal ABC.NET v3.0 сборка 1111
Var
s:string;
i:integer;
begin
readln(s);
while pos('ма',s)<>0 do
delete(s,pos('ма',s),2);
write('Final string:',s,'; длина=',length(s));
end.
Пример ввода:
мастер на все руки
Пример вывода:
Final string:стер на все руки; длина=16
Var
s:string;
i:integer;
begin
readln(s);
while pos('ма',s)<>0 do
delete(s,pos('ма',s),2);
write('Final string:',s,'; длина=',length(s));
end.
Пример ввода:
мастер на все руки
Пример вывода:
Final string:стер на все руки; длина=16
Новые вопросы
Математика,
2 года назад
Физика,
9 лет назад