Информатика, вопрос задал msjuliana07 , 9 лет назад

Составить программу (Turbo Pascal) вычисления величины дохода по вкладу. Процентная ставка (в процентах годовых) и время хранения (в днях) задаются во время работы программы. Ниже представлен рекомендуемый вид диалога во время работы программы. Данные, вводимые пользователем, выделены жирным шрифтом.
Величина вклада (р.) - 25000
Срок вклада (дней) - 30
Годовая процентная ставка (%) - 12
Доход: 252 р. 80 коп.
Сумма по окончании срока вклада: 25252 р. 80 коп.

Ответы на вопрос

Ответил Ruslan2sh
0
{pascal, консольный ввод}

var
    velichina_vklada, srok_vklada, godovaya_procentnaya_stavka: integer;
    vklad_s_procentami: real;
   
    vklad_s_procentami_rub, vklad_s_procentami_kop: integer;
    dohod_rub, dohod_kop: integer;
   
begin
    write('Величина вклада (р.) - ');
    readln();
    write('Срок вклада (дней) - ');
    readln(srok_vklada);
    write('Годовая процентная ставка (%) - ');
    readln(godovaya_procentnaya_stavka);
   
    vklad_s_procentami := velichina_vklada * ((real(100) + real(godovaya_procentnaya_stavka)*real(srok_vklada)/365)/100);
    dohod_rub := (velichina_vklada - integer(vklad_s_procentami));
    dohod_kop := (velichina_vklada*100 - integer(vklad_s_procentami*100)) mod 100;
   
    vklad_s_procentami_rub := integer(vklad_s_procentami);
    vklad_s_procentami_kop := integer((vklad_s_procentami*100)) mod 100;
   
    writeln('Доход: ', dohod_rub,' р. ', dohod_kop, ' 80 коп.');
    writeln('Сумма по окончании срока вклада: ', vklad_s_procentami_rub, ' р. ', vklad_s_procentami_kop, ' коп.');
end.

Ответил Ruslan2sh
0
Кажется так
Новые вопросы