Информатика, вопрос задал andreymits2004 , 7 лет назад

Составить программу-тренажер «Устный счет от 10 до 100», предъявляющую пользователю поочередно примеры на проверку навыков устного счета и проверяющую правильность вычисления пользователем.
Программа должна выводить на экран произвольные два двузначных числа и знак «+» или «-» между ними. Потом пользователь должен ввести свой ответ, а программа проверяет правильность вычислений.

Ответы на вопрос

Ответил Аноним
0

Ответ:

Begin

A :=random(100);

B :=random(100);

If 50>random(100) then ch:='+'

Else ch:='-';

Write(a,ch,b);

Read(o);

If (ch='+' and a+b=o) or (ch='-' and a-b=o) then write('ok')

Else write('wrong');

End.

Новые вопросы