Составить программу суммы только четных чисел (числа целые) из последовательно вводимых чисел, можно осуществить ввод заказного количества чисел. Помогите, отдаю максимум баллов.
Приложения:

Ответы на вопрос
Ответил petyaGavrikov
0
var a,n,s,i:integer;
begin
write('n=');readln(n);
s:=0;
for i:=1 to n do
begin
write('a',i,'='); readln(a);
if a mod 2 =0 then s:=s+a;
end;
writeln('s=',s)
end.
Пример работы программы:
n=5
a1=15
a2=8
a3=7
a4=6
a5=9
s=14
begin
write('n=');readln(n);
s:=0;
for i:=1 to n do
begin
write('a',i,'='); readln(a);
if a mod 2 =0 then s:=s+a;
end;
writeln('s=',s)
end.
Пример работы программы:
n=5
a1=15
a2=8
a3=7
a4=6
a5=9
s=14
Новые вопросы
Физика,
2 года назад
Математика,
9 лет назад