составить программу суммирования натуральных чисел 1...n пока их сумма не превысит величину h. Вывести на экран последнее слагаемое и сумму
Ответы на вопрос
Ответил Wellsfago
0
readln(n,h);
for i:=1 to n do begin
s:=s+i;
if s>h then
break;
end;
writeln(i,s);
for i:=1 to n do begin
s:=s+i;
if s>h then
break;
end;
writeln(i,s);
Ответил nikolac
0
uses crt;
var n,h,i,sum:integer;
begin
read(n,h);
while sum<=h do
begin
sum+=i;
i+=1;
end;
writeln(i-1,' ',sum-i);
end.
var n,h,i,sum:integer;
begin
read(n,h);
while sum<=h do
begin
sum+=i;
i+=1;
end;
writeln(i-1,' ',sum-i);
end.
Ответил Sky09
0
Странно, что мой abc не хочет читать такую запись...
Ответил Sky09
0
а вот паскаль... http://rghost.ru/50608100.view
Ответил nikolac
0
Возможно, надо обновить pascal abc. Ну даже если не заработает - не критично.
Новые вопросы
Геометрия,
2 года назад
Українська мова,
2 года назад
Химия,
10 лет назад
Геометрия,
10 лет назад
Биология,
10 лет назад
Математика,
10 лет назад