Информатика, вопрос задал Maximkakdela , 8 лет назад

Составить программу, содержащую операторы ввода, вывода, присваивания.
9)Найти произведение всех цифр заданного четырехзначного числа.

Ответы на вопрос

Ответил MarshalXaker
0
program znanija;
var a, res:integer;
begin

res := 1;

write('Введите число: ');
readln(a);

while a>1 do
begin
res := res * (a mod 10);
a := a div 10;
end;

writeln('Произведение всех цифр = ', res);
end.
Новые вопросы