Информатика, вопрос задал nbarskova08 , 6 лет назад

Составить программу сколько воскресений в 2022 году

Ответы на вопрос

Ответил NarimanAbu1488
1

Ответ:

a = 2

while a <= 365:

   a += 7

print("Число воскресений в 2022 году", (a-2)//7)

Получим 52 воскресенья

Объяснение:

Первое воскресенье приходится на 2 января. Поэтому нужно прибавлять семь столько раз, пока не выйдем за пределы 365 (т.к. год невисокосный)

Поэтому можно решить следующим образом:

a = 2 #к этой переменной будет прибавлять семерки

while a <= 365: #Пока не выйдем за пределы 365 будем прибавлять к переменной a семерки

   a += 7

#Тогда число воскресений будет

print("Число воскресений в 2022 году", (a-2)//7)

Новые вопросы