Информатика, вопрос задал love9828 , 10 лет назад

. Составить программу, решающую следующую задачу: Вы продавец, и у Вас имеются гири весом  1, 2, 5 кг. Наберите минимальное количество гирь для взвешивания  N кг.Язык программирования-паскаль

Ответы на вопрос

Ответил HRAshton
0
var N, a, b: integer;
begin
     readln(N);
     a := N div 5;
     N := N mod 5;
     b := N div 2;
     WriteLn(a, 'x5, ', b, 'x2, ', N mod 2, 'x1');
end.

Вот так, делением можно)
Новые вопросы