Составить программу, позволяющую определить, имеет ли число, введённое с клавиатуры целый корень( через оператор if)
Ответы на вопрос
Ответил Pantalarax
0
var a:real;
begin readln(a);
if frac(sqrt(a))=0 then write('Да')
else write('Нет');
end.
begin readln(a);
if frac(sqrt(a))=0 then write('Да')
else write('Нет');
end.
Ответил netSt
0
program s;
var i : integer;
begin
readln(i)
if frac(sqrt(i)) = 0 then write('Yes.')
else write ('No.');
end.
var i : integer;
begin
readln(i)
if frac(sqrt(i)) = 0 then write('Yes.')
else write ('No.');
end.
Новые вопросы