Составить программу поиска в целочисленном массиве из 15 элементов двух рядом стоящих элементов, сумма которых больше 10, если таких элементов нет, вывести "NO".
В паскале.
Ответы на вопрос
Ответил StrangeT
0
Const n=15;
var
a: array [1..n] of integer;
i:integer;
p:boolean;
begin
p:=true;
for i:= 1 to n do
begin
write('Введите A[',i,']: ');
readln(a[i]);
end;
i:=1;
while p and (i<n) do
begin
if a[i]+a[i+1]>10 then
begin
p:=false;
writeln;
writeln('(A[',i,']=',a[i],') + ((A[',i+1,']=',a[i+1],') > 10');
end;
inc(i);
end;
writeln;
if p then writeln('NO');
end.
var
a: array [1..n] of integer;
i:integer;
p:boolean;
begin
p:=true;
for i:= 1 to n do
begin
write('Введите A[',i,']: ');
readln(a[i]);
end;
i:=1;
while p and (i<n) do
begin
if a[i]+a[i+1]>10 then
begin
p:=false;
writeln;
writeln('(A[',i,']=',a[i],') + ((A[',i+1,']=',a[i+1],') > 10');
end;
inc(i);
end;
writeln;
if p then writeln('NO');
end.
Новые вопросы
Английский язык,
6 лет назад
История,
6 лет назад
География,
10 лет назад
География,
10 лет назад
Литература,
10 лет назад