Информатика, вопрос задал Anna98111 , 8 лет назад

составить программу поиска элементов массива, значение которых совпадает с индексом.

Ответы на вопрос

Ответил Kатюша69
0
using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;

namespace ConsoleApplication4
{
    class Program
    {
        static void Main(string[] args)
        {
            Console.WriteLine("Введи длину массива");
            int n = int.Parse(Console.ReadLine());
            int[] mass = new int[n];

            for (int i = 0; i < n; i++)
            {
                Console.WriteLine("Введи " + i + " элемент");
                mass[i] = int.Parse(Console.ReadLine());
            }

            for (int i = 0; i < n; i++)
            {
                if (i == mass[i])
                    Console.WriteLine("Элемент " + i + " совпадает со своим индексом");
            }

            Console.ReadKey();
        }
    }
}
Новые вопросы