Информатика, вопрос задал jalelik , 10 лет назад

Составить программу поиска больших чем соседние элементов массива L из 16 чисел. Значения элементов массива рассчитать по формуле CosD/D,где D номер элемента массива.

Ответы на вопрос

Ответил JustPeople
0
VAR
   i: Integer;
   a: Array [1..16] of Real;
BEGIN
    For i := 1 to 16 do begin
        a[i] := Cos(i) / i;
        Writeln('L[',i,'] = ',a[i]); End;

    Writeln;
    For i := 2 to 15 do
        If (a[i] > a[i-1])and(a[i] > a[i+1]) then Writeln('L[',i,'] = ',a[i]);
END.
Новые вопросы