Информатика, вопрос задал megamt , 9 лет назад

Составить программу подсчитывающую сколько дней в январе было с температурой выше, ниже и равной средней температуре месяца

Ответы на вопрос

Ответил mopozko123
0
var 
m: array [1..31] of integer; //заполненный массив 
sr: real;  //средняя сумма 
sum: integer; //сумма всех элементов 
i: integer;  
a: integer;//значений выше 
b: integer;//значений ниже 
c: integer;//равных среднему 
begin 
 for i := 1 to 31 do   
sum := sum + m[i]; 
sr := sum / 31; 
for i := 1 to 31 do   
if m[i] > sr then     
 a := a + 1   
else if m[i] < sr then     
b := b + 1   
else c := c + 1; 
writeln(a); 
writeln(b); 
 writeln(c);
end.
Новые вопросы