Составить программу по которой заполняется массив а [1..30] случайным образом символами английского алфавита (по кодовой таблице от A до Z), а на экран потом выводятся только буквы из этого массива, стоящие до буквы G.
Ответы на вопрос
Ответил applepan
0
program abc;
var a:array[1..30] of integer;
i:integer;
begin
Randomize;
a[1]:= 65+ random (25);
for i:=2 to 30 do
begin
if (a[i-1]=75) or (a[i-1]=0) then a[i]:=0 else a[i]:= 65+ random (25);
if a[i]>0 then write (chr(a[i]),' ');
end;
end.
в таблице ASCII символ G - 75 по номеру , а диапазон алфавита от 65 до 90
Новые вопросы
Английский язык,
2 года назад
Русский язык,
2 года назад
Химия,
7 лет назад
Математика,
7 лет назад
Литература,
9 лет назад