Составить программу перевода целого положительного числа, которое вводится с клавиатуры, из десятичной системы счисления в восьмеричную
систему счисления Pascal
Ответы на вопрос
Ответил student7513
0
Ответ:
Объяснение:
program DecimalToOctal;
var
decimal, remainder: Integer;
octal: String;
begin
Write('Enter a positive decimal number: ');
ReadLn(decimal);
octal := '';
while decimal > 0 do
begin
remainder := decimal mod 8;
decimal := decimal div 8;
octal := IntToStr(remainder) + octal;
end;
WriteLn('Octal equivalent: ', octal);
end.
Ответил WHAAAAAAAAAAAGH
0
Ответ:
На изображении
Приложения:


Новые вопросы
Другие предметы,
1 год назад
География,
1 год назад
Русский язык,
1 год назад
Геометрия,
1 год назад
Музыка,
7 лет назад
Химия,
7 лет назад