Информатика, вопрос задал angel87 , 7 лет назад

Составить программу перестановки первой и последней цифры трехзначного числа.

Ответы на вопрос

Ответил petyaGavrikov
0

var a, a1, a2, a3: integer;

begin

write('a = ');

readln(a);

a1:=a div 100;

a2:=a div 10 mod 10;

a3:=a mod 10;

a:=a3*100+a2*10+a1;

writeln('a = ',a);

end.

Пример:

a = 123

a = 321

Новые вопросы