составить программу Паскаль для нахождения площади трапеции с основаниями а ,б меньшн h
Ответы на вопрос
Ответил djonik2
0
{ s(трапеции) = ((a+b)/2)*h; }
uses crt;
var
a, b, h: Integer; (Real)
s: Real;
begin
WriteLn('Введите а: ',a);ReadLn(a);
WriteLn('Введите b: ',b);ReadLn(b);
WriteLn('Введите h: ',h);ReadLn(h);
s:= ((a+b)/2)*h;
WriteLn('S = ', s);
ReadLn;
end.
Если же а и б должны быть обязательно меньше h, то:
if (a < h) and (b < h) then
begin
WriteLn('Введите а: ',a);ReadLn(a);
WriteLn('Введите b: ',b);ReadLn(b);
WriteLn('Введите h: ',h);ReadLn(h);
s:= ((a+b)/2)*h;
WriteLn('S = ', s);
ReadLn;
end;
else begin
WriteLn('Основания не меньше h!');
ReadLn;
end;
uses crt;
var
a, b, h: Integer; (Real)
s: Real;
begin
WriteLn('Введите а: ',a);ReadLn(a);
WriteLn('Введите b: ',b);ReadLn(b);
WriteLn('Введите h: ',h);ReadLn(h);
s:= ((a+b)/2)*h;
WriteLn('S = ', s);
ReadLn;
end.
Если же а и б должны быть обязательно меньше h, то:
if (a < h) and (b < h) then
begin
WriteLn('Введите а: ',a);ReadLn(a);
WriteLn('Введите b: ',b);ReadLn(b);
WriteLn('Введите h: ',h);ReadLn(h);
s:= ((a+b)/2)*h;
WriteLn('S = ', s);
ReadLn;
end;
else begin
WriteLn('Основания не меньше h!');
ReadLn;
end;
Ответил PĹŚoĹĞÁ123
0
Спасибо )
Новые вопросы