Информатика, вопрос задал nik14888 , 9 лет назад

Составить программу Paskal для:
1)Найти стороны прямоугольника, у которого известны периметр и площадь
2)Дано трехзначное натуральное число. Определить, является ли сумма его цифр двузначным числом

Ответы на вопрос

Ответил Аноним
0
Pascal ABC
1)

Var P,S:real;
Begin
Write('P = ');Read(P);
Write('S = ');Read(S);
if (P/2-sqrt(P*P/4-4*S))/2<0 then S:=(P/2+sqrt(P*P/4-4*S))/2
else S:=(P/2-sqrt(P*P/4-4*S))/2;
WriteLn('Первая сторона равна ',S);
WriteLn('Вторая ',P/2-S);
End.

2)

Var
A:integer;
Begin
Write('A = ');Read(A);
if ((A div 10) mod 10) +(A mod 10)+(A div 100)>9 then Write('Является')
else Write('Не является')
End.



Новые вопросы
Алгебра, 10 лет назад