Составить программу, отгадывающую натуральное четное число, загаданное пользователем. Ниже представлен рекомендуемый вариант диалога во время работы программы:
Загадайте натуральное четное число
Прибавьте к нему 4
Уменьшите на 6
Поделите на 2
Что у вас получилось?
...
Вы загадали число ...!!!
Ответы на вопрос
и какая вероятность что пользователь не ошибется?)))
program i_guess_number;
uses crt;
var changes: array [1..2,1..10] of integer;
i,op,n:integer;
s:string;
res:real;
BEGIN
randomize;
writeln("Загадайте число");
n := 0;
repeat
n := n+1;
i := random(10);
op := random(4);
case op of
1: s := "Прибавте ";
2: s := "Отнимите ";
3: s := "Умножте на ";
else s := "Поделите на ";
end;
writeln(s, i);
changes[1,n] := op; {запоминаем действия}
changes[2,n] := i;
until n = 10;
writeln("Что вышло?");
readln(res);
for i := n downto 1 do { производим обратные действия }
begin
case changes[1,i] of
1: res := res - changes[2,i];
2: res := res + changes[2,i];
3: res := res / changes[2,i];
else res := res * changes[2,i];
end;
end;
writeln("Вы загодали ",res);
END.