Составить программу, определяющую, попадает ли точка с заданными координатами x и y в закрашенную область (использовать формулы уравнения прямой, проходящей через две точки, уравнения окружности, уравнения прямых, параллельных осям координат). Результат работы программы вывести в виде текстового сообщения. (Параметры R, R1, R2, a, b,с вводятся с клавиатуры.) - если имеются
Приложения:

Ответы на вопрос
Ответил lenchikkos
0
отправь нарушение плис ошипся я не знаю
Ответил BobbyFresnel
0
var
x, y, r: real;
begin
read(x, y, R);
if (x * x + y * y <= R * R) or
(y <= 0) and (y >= -2 * x) and (y >= 2 * (x - R)) then
write('попадает')
else
write('не попадает');
end.
Новые вопросы
Английский язык,
1 год назад
Математика,
1 год назад
Українська мова,
1 год назад
Английский язык,
1 год назад
Русский язык,
7 лет назад