составить программу определяющую можно ли построить прямоугольник по четырем заданным отрезкам
Ответы на вопрос
Ответил Аноним
0
// PascalABC.NET 3.1, сборка 1174 от 22.02.2016
begin
var a:=ReadArrInteger('Введите стороны',4).Sorted.ToArray;
if (a[0]=a[1]) and (a[2]=a[3])
then Writeln('Можно построить прямоугольник')
else Writeln('Нельзя построить прямоугольник')
end.
Тестовые решения:
Введите стороны 6 12 12 6
Можно построить прямоугольник
Введите стороны 6 12 12 7
Нельзя построить прямоугольник
begin
var a:=ReadArrInteger('Введите стороны',4).Sorted.ToArray;
if (a[0]=a[1]) and (a[2]=a[3])
then Writeln('Можно построить прямоугольник')
else Writeln('Нельзя построить прямоугольник')
end.
Тестовые решения:
Введите стороны 6 12 12 6
Можно построить прямоугольник
Введите стороны 6 12 12 7
Нельзя построить прямоугольник
Новые вопросы
Русский язык,
2 года назад
Математика,
2 года назад
Математика,
9 лет назад
Геометрия,
9 лет назад
Физика,
9 лет назад