Информатика, вопрос задал svetlana129 , 9 лет назад

Составить программу.Определить, пересекаются ли линии y=b* x^{2}+c*x+d и y=k*x+m.если пересекаются, найти точки пересечения.

Ответы на вопрос

Ответил HRAshton
0
var
  a, b, c, d, k, m: real;

begin
  readln(b, c, d, k, m);
  a := b;
  b := c - k;
  c := d - m;
  d := sqr(b) - 4 * a * c;
  if (a < 0) then
    writeln('Нет точек')
  else
    if (d = 0) then
      writeln('(', (-1 * b + sqrt(d)) / (2 * a), '; ', k * ((-1 * b + sqrt(d)) / (2 * a)) + m, ')')
    else
      writeln('(', (-1 * b + sqrt(d)) / (2 * a), '; ', k * ((-1 * b + sqrt(d)) / (2 * a)) + m, '), (', (-1 * b - sqrt(d)) / (2 * a), '; ', k * ((-1 * b - sqrt(d)) / (2 * a)) + m, ')');
end.
Ответил svetlana129
0
спасибо большое
Новые вопросы