Информатика, вопрос задал tkostromina1 , 9 лет назад

Составить программу определения значений указанных ниже параметров линейного массива. Выполнить программу для длины массива N=8. Сумма положительных элементов массива. Си++

Ответы на вопрос

Ответил iknowthatyoufeelbro
0
#include <iostream>
using namespace std;
const int N = 8; //длина массива
int s = 0; //начальное значение суммы
int mas[N]; //объявляем статический массив длины N
int main()
{
    //вводим элементы массива
    for(int i = 0; i < N; ++i)
    {
        cin >> mas[i];
    }
    //пробегаемся по элементам массива
    for(int i = 0; i < N; ++i)
    {
        if(mas[i] > 0) //если элемент массива больше 0
            s += mas[i]; //прибавляем значение элемента к итоговой сумме
    }
    cout << s; //вывод суммы на экран
    return 0;
}
Ответил tkostromina1
0
спасибо огромное Вам
Ответил nafanyavika32
0
можете помочь написать вот такую программу? Очень нужно.(( Составить программу определения значений указанных ниже линейного массива.Выполнить программу для длины массива N=8 Сумма обратных величин ненулевых элементов массива
Ответил iknowthatyoufeelbro
0
задай отдельный вопрос и кинь в личку ссылку на него
Новые вопросы