Информатика, вопрос задал pro100LiNa , 10 лет назад

составить программу определения задуманного человеком числа от 1 до 1000 с помощюь 10 вопросов.

каждый вопрос имеет вид: задуманное число больше К?(Входные данные:      >К?).

Ответы : ДА(1), Нет(0).

Ответы на вопрос

Ответил Relhem
0
Пробовал, решить невозможно, или я такой дуболом.
Для определения числа в разряде десятков, нужно как минимум 9 вопросов.
Спрашивая "Больше ли оно K" - добиться этого невозможно.
Но могу подсказать начало :)

program dlya_Pro100LiNa;
var a,b,c,d:integer;
m:boolean;
begin
writeln ('Введите число от 1-го до 1000');
repeat read(a) until (a>=1)and(a<=1000);
...
end.

Новые вопросы