Составить программу, объясните. Ввести двухзначное число. Если сумма цифр числа четная, то увеличить число на 2, в противном случае уменьшит на 2
Ответы на вопрос
Ответил hesed
0
Объясняю: создаёте переменную, лучше целочисленную (int foo), после чего можно либо перевести число в строку и найти сумму цифр путём сложения двух символов (sum = bar[0] - '0' + bar[1] - '0'), либо с помощью остатка от деления (конечно, это не очень красиво, но если известно, что число двузначное, то можно так: sum = (foo / 10) + (foo % 10)). Дальше банальная обработка условия: <если сумма чётная (if (sum % 2 == 0)), то увеличить число на 2 (foo += 2), иначе (else) уменьшить число на 2 (foo -= 2)>. После этого можете вывести результат на монитор (printf("%dn", &sum)). :)
Новые вопросы
Русский язык,
2 года назад
Математика,
7 лет назад
Математика,
7 лет назад
Алгебра,
9 лет назад
Геометрия,
9 лет назад