Составить программу нахождения площади треугольника по формуле Герона.
Входные данные длины сторон треугольника.
Выходные данные периметр треугольника, площадь треугольника.
Ответы на вопрос
Ответил frEEze00
0
program abc;
uses crt;
var a,b,c,P,S,P2:real;
begin
writeln('Введите первую сторону: ');
readln(a);
writeln('Введите вторую сторону: ');
readln(b);
writeln('Введите третью сторону: ');
readln(c);
if (a+b<c) or (a+c<b) or (b+c<a) then
writeln('Ваш треугольник не существует')
else
P:=a+b+c;
P2:=P/2;
S:=sqrt(P2*(P2-a)*(P2-b)*(P2-c));
writeln('Периметр = ',P);
writeln('Площадь = ',S);
end.
Новые вопросы