Информатика, вопрос задал Borzechok , 2 года назад

Составить программу нахождения цифр числа, состоящих на нечётных позициях (Dev-C++)

Ответы на вопрос

Ответил Аноним
0
#include <iostream>
#include <locale>
using namespace std;
int main()
{
    setlocale(LC_ALL,"Rus");
    long long int A;
    cout << "Введите целое число: ", cin >> A;
    if (A < 0) A = -A;
    int i = 0;
    while (A > 0)
    {
        if (i++ % 2 != 0) cout << A % 10 << " ";
        A /= 10;
    }
    return 0;
}


Предполагается, что нумерация начинается права, с нулевой позиции.
Чтобы изменить номер начальной позиции, например, на единицу, нужно изменить десятую строку на int i = 1;
Новые вопросы