Информатика, вопрос задал be7ps , 1 год назад

составить программу на языке паскаль: Трое друзей-первоклассников Петя, Ваня и Толя решили подарить своему другу Коле на день рождение настольную игру. Придя в магазин, они достали деньги, которые им дали родители на подарок, и передали их Ване для покупки игры. Ваня подошел к кассе и подал деньги. Написать программу, которая определит, сколько денег кассир должен вернуть Ване.

Формат входных данных: В единственной строке вводятся 4 целых числа: A,B,C,D. Первые три - количество денег у каждого школьника, четверное - стоимость игры.

Формат выходных данных: Выведите одно целое число - количество денег, которые кассир вернет Ване.

Например: я должен ввести в одну строку через пробел четыре числа 2 2 2 4(первые три числа это сколько денег скинул каждый школьник, четвертое число - сколько стоил подарок) и программа должна посчитать сдачу которую даст кассир, то есть вывод на экране будет 2. (2+2+2=6 - скинулись дети; 6-4=2;получившаяся сдача).

Программу сдать в любом виде на любом языке программирования, которую можно будет протестировать при проверке, с открытым кодом.

Ответы на вопрос

Ответил Aniforka
0

Ответ:

program abc;

var a,b,c,d:int64;

begin

  readLn(a,b,c,d);

  writeLn((a+b+c)-d);

end.

Объяснение:

Новые вопросы