Информатика, вопрос задал Лera4ka , 10 лет назад

составить программу на языке паскаль: S= 1-2+3-4+5-...(+,-)n.

помогите пожалуйста)))

 

Ответы на вопрос

Ответил sfc
0

var i,n,s:integer;
begin
  write('n = ');
  readln(n);
  for i:=1 to n do
    if i mod 2 = 0 then dec(s,i) else inc(s,i);
  write('S = ',s)
end.

Ответил Аноним
0

var n,i,rez:integer;
begin
write('Введите n: ');
readln(n);
rez:=0;
for i:=1 to n do
if odd(i) then rez:=rez+i
else rez:=rez-i;
writeln('rez=',rez);
end.

Новые вопросы