Информатика, вопрос задал Alinka200006 , 9 лет назад

составить программу на языке Паскаль по формуле:

Приложения:

Ответы на вопрос

Ответил rusnura
0
var
  S, p, a,b,c : Real;
begin
  writeln('Введите a: ');
  readln(a);
  writeln('Введите b: ');     
  readln(b);     
  writeln('Введите c: ');
  readln(c);     
  // C не может быть = 0     
  if c = 0 then  
     writeln('C не может быть равен 0') 
   else
   begin       
   //Вычисляем P:    
   p := (a+b+c)/c;        
   //Вычисляем корень:    
   S := sqrt( p*(p-a)*(p-b)*(p-c) );
   // Результат:
   writeln('P = ', p);    
   writeln('S = ', S);  
   end;    
end.
Новые вопросы