Информатика, вопрос задал modgood , 2 года назад

Составить программу на языке Паскаль: На координатной плоскости дана точка (х;у). Определите номер координатной четверти.


антагонист: а если точка лежит на оси абсцисс или ординат?
modgood: такого нет)
антагонист: то есть если ввести координаты (1;0) то программа выдаёт : это невозможно?

Ответы на вопрос

Ответил антагонист
3
var x,y:integer;
begin
 writeln('введите x');
 readln(x);
 writeln('введите y');
 readln(y);
  if (x>0) and (y>0) then writeln ('точка лежит в первой четверти');
  if (x<0) and (y>0) then writeln ('точка лежит во второй четверти');
  if (x>0) and (y<0) then writeln ('точка лежит в четвёртой четверти');
  if (x<0) and (y<0) then writeln ('точка лежит в третьей четверти');
   if (x=0) or (y=0) then writeln ('такой точки нет');
  end.
Новые вопросы