Информатика, вопрос задал drzan , 9 лет назад

составить программу на языке паскаль которая меняет местами два числа без ввода дополнительной ячейки

Ответы на вопрос

Ответил Halavina
0
a:=a+b;
b:=a-b;
a:=a-b;

var a,b:real;
procedure change(var a, b: real);
begin
a := a + b; writeln(a);  
b := a - b; writeln(b);  
a := a - b; writeln(a);
end;
begin
writeln('a, b:');  
readln(a, b);  
writeln('a=', a);  
writeln('b=', b);  
change(a, b);  
writeln('a=', a);  
writeln('b=', b);  
readln;
end.
Новые вопросы