Информатика, вопрос задал linakamaewa , 9 лет назад

Составить программу на языке паскаль:
Две точки задаются своими координатами. Определите, какая из них находится дальше от:
начала координат;
окружности заданного радиуса с центром в начале координат.

Ответы на вопрос

Ответил kage1998
0
program gt;
var x1,y1,x2,y2,r:real;
begin
readln(x1,y1,x2,y2);
readln(r);
if((sqr(x1)+sqr(y1))<(sqr(x2)+sqr(y2)))then writeln('Pervaya')else
writeln('2-raya');
if(abs(sqrt(sqr(x1)+sqr(y1))-r)<abs(sqrt(sqr(x2)+sqr(y2))-r))
then writeln('Pervaya-ornositelno okru') else writeln('2-raya otnositelno okru');
end.
Ответил linakamaewa
0
then writeln('Pervaya-otnositelno okru') else writeln('2-raya otnositelno okru'); ошибку в этой строке выдает
Ответил kage1998
0
сейчас исправлю
Ответил kage1998
0
проверь
Ответил linakamaewa
0
заработала) спасибо большое:)
Ответил kage1998
0
ок
Новые вопросы