Составить программу на языке Паскаль для решения следующей задачи:
Дан одномерный массив. В массиве хранятся оценки по информатике учеников 9 класса. Заполнить массив случайными числами, лежащими в диапазоне от 2 до 5 включительно. Вычислите среднюю оценку в классе по информатике. Входные данные для размерности массива задайте самостоятельно.
Ответы на вопрос
Ответил huston81
21
Ответ:
pascal
Объяснение:
var a: array of integer;
n, i, s: integer;
begin
Write('Введите количество учеников в классе: ');
ReadLn(n);
SetLength(a, n);
WriteLn('Оценки учеников:');
for i := 0 to n - 1 do
begin
a[i] := random(4) + 2;
Write(a[i], ', ');
s := s + a[i];
end;
WriteLn;
WriteLn('Средняя оценка в классе: ', s / n:1:2);
end.
KreiserA:
почему оценки низкие? программа работает... или за нее ставят 2 (интернетурок), как за списанную?...
Новые вопросы