Информатика, вопрос задал JuleTaylor , 10 лет назад

Составить программу на языке pascal. используя цикл repeat...until.

 

Определить минимальное число из введенной с клавиатуры последовательности положительных чисел, ввод заканчивается отрицательным числом.

Ответы на вопрос

Ответил Hasl1337
0

var
  a, min: integer;
begin
  min := 1000;
  repeat
    readln(a);
    if(a < min) and (a >= 0) then min := a;
  until(a < 0);
  writeln('Минимальное число: ', min);
end.

Новые вопросы