Составить программу на языке Pascal.
Дано: а1, а2, а3, - производное.
Найти: min
антагонист:
a1 a2 a3 сам вводишь?
Ответы на вопрос
Ответил NameOff
1
var a1, a2, a3, min : integer;
begin
readln(a1, a2, a3);
min := a1;
if min > a2 then min := a2;
if min > a3 then min := a3;
writeln(min);
end.
begin
readln(a1, a2, a3);
min := a1;
if min > a2 then min := a2;
if min > a3 then min := a3;
writeln(min);
end.
Ответил антагонист
1
program bit;
var m,a1,a2,a3:
integer;
begin
writeln('введите три числа');
readln(a1,a2,a3);
if (a1<a2) and (a1<a3) then m:=a1;
if (a2<a1) and (a2<a3) then m:=a2;
if (a3<a1) and (a3<a2) then m:=a3;
if (a1=a2) and (a1=a3) then
writeln('они равны')
else writeln('меньшее из трёх ',m);
end.
var m,a1,a2,a3:
integer;
begin
writeln('введите три числа');
readln(a1,a2,a3);
if (a1<a2) and (a1<a3) then m:=a1;
if (a2<a1) and (a2<a3) then m:=a2;
if (a3<a1) and (a3<a2) then m:=a3;
if (a1=a2) and (a1=a3) then
writeln('они равны')
else writeln('меньшее из трёх ',m);
end.
Новые вопросы