Информатика, вопрос задал DJ2402 , 7 лет назад

Составить программу на Паскале:

Заполнить массив ВМ случайными числами из диапазона от 1 до 150. Размерность массива 20.

Распечатать массив на экране в строку. Найти сумму всех нечётных чисел массива. Результат вывести на экран в отдельной строке.

Ответы на вопрос

Ответил gelyamark2003
0
  1. program n_1;
  2. const
  3.  n = 20;
  4. var
  5.  a: array [1..n] of integer;
  6.  i, sum: integer;
  7. begin
  8.  sum := 0;
  9.  for i := 1 to n do  
  10.  begin
  11.    a[i] := random(150) + 1;
  12.    write('a[', i, '] = ', a[i], '; ');
  13.    if odd(a[i]) then inc(sum, a[i]);  
  14.  end;
  15.  writeln ();
  16.  write('sum = ', sum);
  17. end.
Новые вопросы