Составить программу на Паскале для нахождения выражения, прошу
Приложения:

Ответы на вопрос
Ответил HRAshton
0
var
x: longint;
begin
write('x = ');
readln(x);
write('y = ');
case x of
-2147483648..-2:
writeln(sqr(x) - 2 * x + 1);
2..2147483647:
writeln(sqr(x) + 2 * x - 1);
else
writeln(sqr(x));
end;
end.
x: longint;
begin
write('x = ');
readln(x);
write('y = ');
case x of
-2147483648..-2:
writeln(sqr(x) - 2 * x + 1);
2..2147483647:
writeln(sqr(x) + 2 * x - 1);
else
writeln(sqr(x));
end;
end.
Ответил bang123
0
Вопрос можно? Case что это
Ответил HRAshton
0
Выборка, через if, как я понимаю, слишком просто, чтобы приняли, посему решил задачу с помощью case of, нижние границы Int32 известны с первого урока, насколько я знаю
Новые вопросы
Английский язык,
2 года назад
Алгебра,
9 лет назад
Математика,
9 лет назад
Химия,
10 лет назад
Биология,
10 лет назад