Информатика, вопрос задал gorlovich2015 , 9 лет назад

составить программу на нахождение макимального значения в массиве чисел.

Ответы на вопрос

Ответил WhitePineapple
0
var
a:array[1..10] of real;
i,na:integer;
max:real;
begin
repeat
      writeln('Введите количество элементов массива меньше 11');
      readln(na);
until (na>0) and(na<=10);
writeln('Введите элементы массива,',na,' штук');
for i:=1 to na do
    begin
    readln(a[i]);
    if i=1 then max:=a[i]
    else
    if (a[i]>max) then max:=a[i];
    end;
writeln('Наибольший элемент массива = ',max);
end.

Новые вопросы