Информатика, вопрос задал КотЭйка1337 , 2 года назад

Составить программу на C++ для решения следующей задачи.
Дан массив А, состоящий из 10 действительных чисел. Обменять местами минимальный и последний элемент массива. Массив заполнить с клавиатуры и вывести на экран.

Ответы на вопрос

Ответил Аноним
0

#include <iostream>

#include <vector>

using namespace std;

void swap(int *a, int *b){

   int temp = *a;

   *a = *b;

   *b = temp;

}

signed main() {

   const int n = 10;

   vector<int> a(n);

   int mx = -INT_MAX, mn = INT_MAX, i = 0, j = 0;

   for(int k = 0; k < n; k++){

       cin >> a[k];

       if(a[k] > mx){mx = a[k]; i = k;}

       if(a[k] < mn){mn = a[k], j = k;}

   }

   swap(a[i],a[j]);

   for(auto &i:a)

       cout << i << " ";

}

Новые вопросы